Learn Autodesk Inventor 2018 Basics

3D Modeling, 2D Graphics, and Assembly Design

T. Kishore
Learn Autodesk Inventor 2018 Basics

3D Modeling, 2D Graphics, and Assembly Design

T. Kishore
## Contents

**About the Author** ........................................................................................................................................... xi

**About the Technical Reviewer** ................................................................................................................... xiii

**Introduction** .................................................................................................................................................. xv

### Chapter 1: Getting Started with Autodesk Inventor 2018 ................................................................. 1

**Starting Autodesk Inventor** ......................................................................................................................... 2

**Exploring the User Interface** ..................................................................................................................... 3

- Ribbon ....................................................................................................................................................... 3
- File Menu .................................................................................................................................................. 6
- Quick Access Toolbar .............................................................................................................................. 7
- Browser Window ...................................................................................................................................... 8
- Status Bar ................................................................................................................................................ 8
- Navigation Bar ......................................................................................................................................... 8
- ViewCube ................................................................................................................................................ 9
- Shortcut Menus and Marking Menus ....................................................................................................... 10
- Dialogs ................................................................................................................................................... 11

**Using the Mini-Toolbar** ............................................................................................................................. 12

**Customizing the Ribbon, Shortcut Keys, and Marking Menus** ............................................................ 12

**Exploring the Color Settings** ................................................................................................................... 14

### Chapter 2: Part Modeling Basics ............................................................................................................ 15

**Tutorial 1** ................................................................................................................................................. 15

- Creating a New Project ............................................................................................................................ 16
- Starting a New Part File ........................................................................................................................... 16
- Starting a Sketch ..................................................................................................................................... 17
Adding Dimensions ................................................................................................................................. 18
Creating the Base Feature ......................................................................................................................... 19
Adding an Extruded Feature ..................................................................................................................... 24
Adding Another Extruded Feature .......................................................................................................... 28
Saving the Part ........................................................................................................................................ 31

Tutorial 2 .................................................................................................................................................. 31
Starting a New Part File .............................................................................................................................. 32
  Sketching a Revolve Profile ....................................................................................................................... 32
  Creating the Revolved Feature ................................................................................................................ 35
  Creating the Cut Feature ........................................................................................................................ 36
  Creating Another Cut Feature ............................................................................................................... 39
  Adding a Fillet .......................................................................................................................................... 43
  Saving the Part ....................................................................................................................................... 44

Tutorial 3 .................................................................................................................................................. 44
  Starting a New Part File........................................................................................................................... 45
  Creating the Cylindrical Feature ........................................................................................................... 45
  Creating Cut Feature ............................................................................................................................ 46
  Saving the Part ....................................................................................................................................... 48

Tutorial 4 .................................................................................................................................................. 48
  Starting an Extruded Feature .................................................................................................................. 48
  Applying Draft ....................................................................................................................................... 49
  Saving the Part ....................................................................................................................................... 51

Chapter 3: Assembly Basics ..................................................................................................................... 53
Tutorial 1 .................................................................................................................................................. 53
  Top-Down Approach ............................................................................................................................... 54
  Bottom-Up Approach .............................................................................................................................. 54
  Starting a New Assembly File ................................................................................................................ 54
  Inserting the Base Component ............................................................................................................. 55
  Adding the Second Component ............................................................................................................. 56
  Applying Constraints ............................................................................................................................. 56
  Adding the Third Component ................................................................................................................. 67
Contents

Checking the Interference .......................................................... 72
Saving the Assembly ............................................................... 73
Starting the Main Assembly ...................................................... 74
Adding a Disc to the Assembly .................................................. 74
Placing the Subassembly ......................................................... 74
Adding Constraints ............................................................... 74
Placing the Second Instance of the Subassembly ....................... 78
Saving the Assembly ............................................................... 78

Tutorial 2 ................................................................................. 79
Starting a New Presentation File ................................................. 79
Creating a Storyboard Animation .............................................. 80
Animating the Explosion ......................................................... 86
Taking a Snapshot of the Explosion ......................................... 87

Chapter 4: Creating Drawings .................................................. 89

Tutorial 1 .................................................................................. 89
Starting a New Drawing File ...................................................... 90
Editing the Drawing Sheet ....................................................... 91
Generating the Section View .................................................... 94

Tutorial 2 .................................................................................. 107
Creating a New Sheet Format .................................................. 107
Creating a Custom Template .................................................... 114
Starting a Drawing Using the Custom Template ......................... 116

Tutorial 3 .................................................................................. 119
Creating a New Drawing File .................................................... 120
Generating the Base View ....................................................... 120
Generating the Exploded View .................................................. 121
Configuring the Parts List Settings ........................................... 122
Creating the Parts List ........................................................... 123
Creating Balloons ................................................................. 124
Saving the Drawing ............................................................... 125
Chapter 5: Additional Modeling Tools ......................................................... 127

Tutorial 1 .................................................................................................. 128
  Creating the First Feature........................................................................ 128
  Adding the Second Feature .................................................................... 136
  Creating a Counterbore Hole .................................................................. 137
  Creating a Threaded Hole ........................................................................ 139
  Creating a Circular Pattern .................................................................... 142
  Creating Chamfers.................................................................................. 143

Tutorial 2 .................................................................................................. 145
  Creating the First Feature........................................................................ 146
  Creating the Shell Feature ...................................................................... 149
  Creating the Third Feature ..................................................................... 151
  Creating a Cut Feature .......................................................................... 154
  Creating the Rib Feature ....................................................................... 156

Tutorial 3 .................................................................................................. 160
  Creating the Coil..................................................................................... 160

Tutorial 4 .................................................................................................. 164
  Creating the First Section and Rails ....................................................... 164
  Creating the Second Section .................................................................. 172
  Creating the Loft Feature ....................................................................... 174
  Creating the Extruded Feature .............................................................. 175
  Creating the Emboss Feature .................................................................. 176
  Mirroring the Emboss Feature ................................................................. 179
  Creating Fillets....................................................................................... 179
  Shelling the Model................................................................................. 182
  Adding Threads....................................................................................... 183

Tutorial 5 .................................................................................................. 191
  Creating a 3D Sketch............................................................................... 192
  Creating the Sweep Feature ................................................................... 202
  Creating the Along Curve Pattern ......................................................... 206
  Creating the Free-Form Feature ............................................................ 209
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing the Free-Form Shape</td>
<td>213</td>
</tr>
<tr>
<td>Create Another Free-Form Box</td>
<td>215</td>
</tr>
<tr>
<td><strong>Tutorial 6</strong></td>
<td>218</td>
</tr>
<tr>
<td>Starting a New Part File</td>
<td>219</td>
</tr>
<tr>
<td>Creating the Second Feature</td>
<td>220</td>
</tr>
<tr>
<td>Adding Threads</td>
<td>223</td>
</tr>
<tr>
<td>Creating iParts</td>
<td>224</td>
</tr>
<tr>
<td><strong>Tutorial 7</strong></td>
<td>232</td>
</tr>
<tr>
<td>Creating the First Feature</td>
<td>232</td>
</tr>
<tr>
<td>Creating the Extruded Surface</td>
<td>237</td>
</tr>
<tr>
<td>Replacing the Top Face of the Model with the Surface</td>
<td>238</td>
</tr>
<tr>
<td>Creating a Face Fillet</td>
<td>239</td>
</tr>
<tr>
<td>Creating a Variable Radius Fillet</td>
<td>240</td>
</tr>
<tr>
<td>Mirroring the Fillet</td>
<td>243</td>
</tr>
<tr>
<td>Shelling the Model</td>
<td>244</td>
</tr>
<tr>
<td>Creating the Boss Features</td>
<td>244</td>
</tr>
<tr>
<td>Creating the Lip Feature</td>
<td>249</td>
</tr>
<tr>
<td>Creating the Grill Feature</td>
<td>252</td>
</tr>
<tr>
<td>Creating Ruled Surface</td>
<td>255</td>
</tr>
<tr>
<td><strong>Tutorial 8</strong></td>
<td>256</td>
</tr>
<tr>
<td><strong>Tutorial 9</strong></td>
<td>260</td>
</tr>
<tr>
<td><strong>Tutorial 10</strong></td>
<td>262</td>
</tr>
<tr>
<td><strong>Chapter 6: Sheet Metal Modeling</strong></td>
<td>265</td>
</tr>
<tr>
<td><strong>Tutorial 1</strong></td>
<td>265</td>
</tr>
<tr>
<td>Starting a New Sheet Metal File</td>
<td>266</td>
</tr>
<tr>
<td>Setting the Parameters of the Sheet Metal Part</td>
<td>266</td>
</tr>
<tr>
<td>Creating the Base Feature</td>
<td>270</td>
</tr>
<tr>
<td>Creating the Flange</td>
<td>271</td>
</tr>
<tr>
<td>Creating the Contour Flange</td>
<td>272</td>
</tr>
<tr>
<td>Creating the Corner Seam</td>
<td>275</td>
</tr>
<tr>
<td>Creating a Sheet Metal Punch iFeature</td>
<td>277</td>
</tr>
</tbody>
</table>
Creating a Punched Feature ................................................................................................................................. 284
Creating the Rectangular Pattern .............................................................................................................................. 286
Creating the Bend Feature .......................................................................................................................................... 289
Applying a Corner Round .......................................................................................................................................... 292
Creating Countersink Holes ...................................................................................................................................... 293
Creating Hem Features ............................................................................................................................................... 296
Mirroring the Features .................................................................................................................................................. 298
Creating the Flat Pattern ........................................................................................................................................... 300
Creating 2D Drawing of the Sheet Metal Part ........................................................................................................... 302

Chapter 7: Top-Down Assembly and Joints ............................................................................................................. 307

Tutorial 1 ..................................................................................................................................................................... 307
Creating a New Assembly File .................................................................................................................................... 308
Creating a Component in the Assembly ...................................................................................................................... 308
Creating the Second Component of the Assembly ...................................................................................................... 315
Creating the Third Component of the Assembly ........................................................................................................ 318
Adding Bolt Connections to the Assembly .................................................................................................................. 321
Patterning Components in an Assembly ..................................................................................................................... 325
Applying the Constraint to the Components ............................................................................................................. 327
Using the Search tool in the Browser Window ........................................................................................................... 329
Editing Values in the Browser Window ....................................................................................................................... 331
Changing the Display Preferences of the Browser Window .......................................................................................... 333
Using the Measure Tool ............................................................................................................................................. 334

Tutorial 2 ..................................................................................................................................................................... 338
Creating the Slider Joint .............................................................................................................................................. 340
Creating the Rotational Joint ....................................................................................................................................... 345
Creating the Rigid Joint .............................................................................................................................................. 347
Adding More Assembly Joints ...................................................................................................................................... 349
Driving the Joints .......................................................................................................................................................... 352
Creating Positions ...................................................................................................................................................... 354
Creating 3D PDF ......................................................................................................................................................... 356
Chapter 8: Dimensions and Annotations ......................................................... 359
Tutorial 1 ........................................................................................................... 360
   Creating Centerlines and Centered Patterns .................................................. 362
   Editing the Hatch Pattern ............................................................................ 365
   Applying Dimensions .................................................................................... 366
   Placing the Feature Control Frame ............................................................... 377
   Placing the Surface Texture Symbols ........................................................... 379
   Modifying the Title Block Information ......................................................... 381

Chapter 9: Model-Based Dimensioning .............................................................. 383
Geometric Dimensioning and Tolerancing ....................................................... 383
Tutorial 1 ........................................................................................................... 384
   Adding Tolerances to the Model Dimensions .............................................. 386
   Extracting the Model Dimensions ............................................................... 389
   Adding Tolerance Feature .......................................................................... 391

Index .................................................................................................................. 397
T. Kishore is an experienced trainer, savvy engineer, and prolific author of several books on Autodesk and other tools for engineering, design, graphics, 3D printing, and more.
Wallace Jackson has been writing for leading multimedia publications about his work in new media content development since the advent of Multimedia Producer Magazine nearly two decades ago. He has authored a half-dozen Android books for Apress, including four books in the popular Pro Android series. Wallace received his undergraduate degree in business economics from the University of California at Los Angeles and a graduate degree in MIS design and implementation from the University of Southern California. He is currently the CEO of Mind Taffy Design, a new media content production and digital campaign design and development agency.
Introduction

Autodesk Inventor as a topic of learning is vast, with a wide scope. It is a package of many modules that deliver great value to enterprises. It offers a set of easy-to-use tools for designing, documenting, and simulating 3D models. Using this software, you can speed up the design process and reduce your product development costs.

This book provides a step-by-step approach for users to learn Autodesk Inventor. It is aimed at those with no previous experience with Inventor. However, users of previous versions of Inventor may find this book useful to learn about the new and enhanced features of Inventor 2018. You will be guided from starting an Autodesk Inventor 2018 session to creating parts, assemblies, and drawings. Each chapter explains the components with the help of real-world models.

Scope of This Book

This book was written for students and engineers who are interested in using Autodesk Inventor 2018 to design mechanical components and assemblies and then create drawings.

This book provides a step-by-step approach for learning Autodesk Inventor 2018. The chapters cover the following topics:

- **Chapter 1** introduces Autodesk Inventor. The user interface and terminology are discussed in this chapter.
- **Chapter 2** takes you through the creation of your first Inventor model. You create simple parts.
- **Chapter 3** teaches you to create assemblies. It explains the top-down and bottom-up approaches for designing an assembly. You create an assembly using the bottom-up approach.
- **Chapter 4** teaches you to create drawings of the models created in the earlier chapters. You also place exploded views and the part list of an assembly.
- **Chapter 5** teaches you how to use additional modeling tools to create complex models.
- **Chapter 6** introduces you to sheet metal modeling. You create a sheet metal part using the tools available in the Sheet Metal environment.
- **Chapter 7** teaches you to create top-down assemblies. It also introduces you to creating mechanisms by applying joints between the parts.
- **Chapter 8** teaches you to apply dimensions and annotations to a 2D drawing.
- **Chapter 9** teaches you to add 3D annotations and tolerances to a 3D model.
CHAPTER 1

Getting Started with Autodesk Inventor 2018

This chapter covers the most commonly used features of Autodesk Inventor. In this chapter, you will do the following:

- Understand the Inventor terminology
- Start a new file
- Understand the user interface
- Understand different environments in Inventor

In this chapter, you will learn some of the most commonly used features of Autodesk Inventor. In addition, you will learn about the user interface.

In Autodesk Inventor, you create 3D parts and use them to create 2D drawings and 3D assemblies. Inventor is feature-based. Features are shapes that are combined to build a part. You can modify these shapes individually.
Most of the features are sketch-based. A sketch is a 2D profile and can be extruded, revolved, or swept along a path to create features.

Inventor is parametric in nature. You can specify standard parameters between the elements. Changing these parameters changes the size and shape of the part. For example, see the following design of the body of a flange before and after modifying the parameters of its features:

Starting Autodesk Inventor

To start Autodesk Inventor, follow these steps:

1. Click the Start button on the Windows taskbar.
2. Click All Programs.
4. On the ribbon, click Get Started ➤ Launch ➤ New.
5. In the Create New File dialog, click the Templates folder located at the top-left corner. You can also select the Metric folder to view various metric templates.
6. In the Part – Create 2D and 3D Objects section, click the Standard.ipt icon.
7. Click Create to start a new part file.
Notice these important features of the Inventor window:

Exploring the User Interface
Various components of the user interface are discussed next.

Ribbon
The ribbon is located at the top of the window. It consists of various tabs. When you click a tab, several tools appear. These tools are arranged in panels. You can select the required tool from a panel. The following sections explain the various tabs of the ribbon available in Autodesk Inventor.

The Get Started Ribbon Tab
This ribbon tab contains tools such as New, Open, Projects, and so on.
The 3D Model Ribbon Tab

This ribbon tab contains the tools to create 3D features, planes, surfaces, and so on.

The View Ribbon Tab

This ribbon tab contains the tools to modify the display of the model and user interface.

The Inspect Ribbon Tab

This ribbon tab has tools to measure the objects. It also has analysis tools to analyze the draft, curvature, surface, and so on.

The Sketch Ribbon Tab

This ribbon tab contains all the sketch tools.
The Assemble Ribbon Tab

This ribbon tab contains the tools to create an assembly. It is available in an assembly file.

The Presentation Ribbon Tab

This tab contains the tools to create the exploded views of an assembly. It also has the tools to create presentations, assembly instructions, and animations of an assembly.

The Drawing Environment Ribbon Tab

In the Drawing environment, you can create print-ready drawings of a 3D model. The ribbon tabs in this environment contain tools to create 2D drawings.

The Place Views Ribbon Tab

This ribbon tab has commands and options to create and modify drawing views on the drawing sheet.

The Annotate Ribbon Tab

This ribbon tab has commands and options to add dimensions and annotations to the drawing views.
The Sheet Metal Ribbon Tab

The tools in this tab are used to create sheet metal components.

File Menu

The File menu appears when you click the File tab located at the top-left corner. This menu contains the options to open, print, export, manage, save, and close a file.
Quick Access Toolbar

This is available at the top left of the window. It contains the tools such as **New**, **Save**, **Open**, and so on.

You can customize this toolbar by clicking the down arrow on the right side of this toolbar.
Browser Window

The Browser window is located on the left side of the window. It contains the list of operations carried in an Autodesk Inventor file.

Status Bar

This is available below the Browser window. It displays the prompts and actions taken while using the tools.

Navigation Bar

This is located at the right side of the window. It contains the tools to zoom, rotate, pan, or look at a face of the model.
ViewCube

The ViewCube is located at the top-right corner of the graphics window. It is used to set the view orientation of the model.
Shortcut Menus and Marking Menus

When you right-click, a shortcut menu along with a marking menu appears. A shortcut menu contains a list of some important options. The marking menu contains important tools. It allows you to access the tools quickly. You can customize the marking menu by adding and removing tools.
Dialogs

When you activate any tool in Autodesk Inventor, the dialog related to it appears. The dialog consists of various options that help you to complete the operation. The following figure shows the components of a dialog:
Using the Mini-Toolbar

The mini-toolbar appears in the dialog boxes of the Extrude, Revolve, Fillet, Shell, Face Draft, Chamfer, and Joint commands. However, in Autodesk Inventor 2018, the mini-toolbar does not appear by default. You need to check the Mini-Toolbar option available in the User Interface drop-down of the Windows panel of the View ribbon tab to display the mini-toolbar.

Customizing the Ribbon, Shortcut Keys, and Marking Menus

To customize the ribbon, shortcut keys, or marking menus, click Tools ➤ Options ➤ Customize on the ribbon. In the Customize dialog, use the tabs to customize the ribbon, marking menu, or shortcut keys.

For example, to add a command to the ribbon, select the command from the list on the left side of the dialog and click the Add button. If you want to remove a command from the ribbon, then select it from the right-side list and click the Remove button. Click OK to make the changes take effect.
To add or remove panels from the ribbon, click the **Show Panels** icon located on the right side of the ribbon and check/uncheck the options on the fly-out menu.
Exploring the Color Settings

To change the background color of the window, click **Tools ➤ Options ➤ Application Options** on the ribbon. In the **Application Options** dialog, click the **Colors** tab in the dialog. Set the **Background** value to **1 Color** to change the background to plain. Select the required color scheme from the **Color Scheme** group. Click **OK**.
CHAPTER 2

Part Modeling Basics

This chapter takes you through the creation of your first Inventor model. You will create simple parts. In this chapter, you will do the following:

- Create sketches
- Create a base feature
- Add another feature to it
- Create revolved features
- Create cylindrical features
- Create box features
- Apply draft

Tutorial 1

This tutorial takes you through the creation of your first Inventor model. You will create the disc of an Oldham coupling.
Creating a New Project

Follow these steps:

1. Start Autodesk Inventor 2018 by double-clicking the Autodesk Inventor 2018 icon on your desktop.
2. To create a new project, click Get Started ➤ Launch ➤ Projects on the ribbon.
3. Click the New button in the Projects dialog.
4. In the Inventor project wizard dialog, select New Single User Project and click the Next button.
5. Enter Oldham Coupling in the Name field.
6. Enter C:\Users\Username\Documents\Inventor\Oldham Coupling\ in the Project (Workspace) Folder box and click Next.
7. Click Finish.
8. Click OK in the Inventor Project Editor dialog.
9. Click Done.

Starting a New Part File

Follow these steps:

1. To start a new part file, click Get Started ➤ Launch ➤ New on the ribbon.
2. In the Create New File dialog, click the Templates folder located in the top-right corner.
3. Click the Standard.ipt icon located in the Part – Create 2D and 3D Objects section.
4. Click the Create button in the Create New File dialog.

A new model window appears.
Starting a Sketch

Follow these steps:

1. To start a new sketch, click 3D Model ➤ Sketch ➤ Start 2D Sketch on the ribbon.

2. Click the XY plane. The sketch starts.

The first feature is an extruded feature from a sketched circular profile. You will begin by sketching the circle.

3. On the ribbon, click Sketch ➤ Create ➤ Circle ➤ Circle Center Point.

4. Move the cursor to the sketch origin located at the center of the graphics window and then click it.

5. Drag the cursor up to a random location and then click to create a circle.